Answered "Device not compatible" can't register my xiaomi at wizards unite android apk :((((

Mar 27, 2019
7
5
4
"Device not compatible" can't register my xiaomi at wizards unite android apk :((((

hi! just tried to pre-register to the android app but it shows this message: "Device not compatible"

anyone else??
 

livoruc

Auror
Feb 18, 2019
58
27
23
Hi! Found this list, hope it helps:
Phones compatible with Wizards Unite (confirmed):

  • Pocophone F1
  • OnePlus 3T+
  • Samsung Galaxy S6, S7, S8, S9, S10
  • Samsung Note 9
  • Samsung A3 )2017(
  • Pixel 1XL, Pixel 3XL
  • Huawei P10
  • Huawei P20 Lite
  • Huawei Honor 8
  • Sony XPeria Z3
  • LG G6+
  • Zenfone 3
Phones not compatible with Wizards Unite (confirmed):

  • Alcatel A30 tablet
  • LG Phoenix 4
  • LG Fortune 2
  • LG K10
  • Samsung S4 Mini
  • Samsung Galaxy Gran Duos Prime TV ( Android 5.1.1)
  • Samsung Galaxy J5
  • Samsung Galaxy J6
  • Samsung Galaxy J7 (2016), android 8.1.0
  • Samsung Galaxy ON5
  • Sony Xperia E5
  • Sony Xperia XA1
  • Moto G 4 Play (Android 7.1.1)
  • Moto G Turbo Edition
  • Xiaomi 5A
  • Xiaomi Redmi 6
  • Huawei Nova 2i
  • Huawei P9 lite
  • Huawei Mate 10 Lite
  • Huawei Y6 2018
Anyway, I'm pretty sure they solve these problems soon and most of these non-compatible devices will be approved before wizards unite beta release.
 

RichardSly

Auror
Feb 13, 2019
60
45
25
Profession
Auror
School
Hogwarts
Houses
Slytherin
Xiaomi Redmi Note 6 works great. From what I've read the issues come with phones that are not fully compatible with AR technology. It's perfectly possible that while you can't pre-register you might be able to download the game once it's out, though. AR seems to be an added bonus to the game, but not entirely necessary, so perhaps they're limiting the devices so it's easier to manage the beta release. They might make it available for everyone once the proper version is out.
As for the specs, I think they were mentioned in a post in the blog here. They seem to be the same as the ones for P籀kemonGO.
Hope that helps!
 
  • Like
Reactions: livoruc

Wizdreamer

Auror
Feb 13, 2019
63
23
15
Melbourne
Profession
Auror
School
Hogwarts
Houses
Gryffindor
"Device not compatible" can't register my xiaomi at wizards unite android apk :((((

hi! just tried to pre-register to the android app but it shows this message: "Device not compatible"

anyone else??
Which is your model? Are you using a custom ROM??
 

magichocolo

Newbie
Auror
Jun 24, 2019
4
0
2
My phone (Sony Xperia Z5 Compact) is not listed on either the compatible or non-compatible lists, i have tried to download the game but says that my 'device is not compatible with this version'
What do i do? I have been waiting with baited breath for this to come out since it was announced
I heard that if you download the apk you can play. No matter which device you have.
 
Feb 28, 2019
86
14
13
Hey, I easily got through the process of pre-registration. This was pretty smooth. @errol , you can give it another try and see how it works.
 
Feb 14, 2019
92
24
13
I would suggest you to verify your Rom and/or OS. That may need to be upgraded; because all of us were able to pre-registered successfully without any issues!
 

Breixo

Staff member
Feb 9, 2019
244
127
55
acciowizardsunite.com
Profession
Magizoologist
School
Hogwarts
Houses
Ravenclaw
FriendsCode
442519873495
Thread moved to questions and answers.
Thanks @livoruc for the list!
@errol I'm sure you won't have problems to play. Just wait a little and they'll fix it :)

PS: my Xiaomi Redmi Note 5 was pre-registered without problems.
PS2: keep sharing your devices!!
 
  • Like
Reactions: casafei and livoruc